aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Mehdi Goli <mehdi.goli@codeplay.com>2016-10-14 12:09:55 +0100
committerGravatar Mehdi Goli <mehdi.goli@codeplay.com>2016-10-14 12:09:55 +0100
commit524fa4c46f8c5c1bc01f7754188e6883f669a543 (patch)
tree4e52325e02ed13d361cb28db86a2b6c255aea6e3 /unsupported/test/CMakeLists.txt
parentd7f9679a34ef991fa3c9da8f61510d6c48aaa19c (diff)
Reducing the code by generalising sycl backend functions/structs.
Diffstat (limited to 'unsupported/test/CMakeLists.txt')
-rw-r--r--unsupported/test/CMakeLists.txt14
1 files changed, 6 insertions, 8 deletions
diff --git a/unsupported/test/CMakeLists.txt b/unsupported/test/CMakeLists.txt
index 17073dfa7..aeaea162a 100644
--- a/unsupported/test/CMakeLists.txt
+++ b/unsupported/test/CMakeLists.txt
@@ -140,6 +140,12 @@ endif()
endif()
if(EIGEN_TEST_CXX11)
+ if(EIGEN_TEST_SYCL)
+ ei_add_test_sycl(cxx11_tensor_sycl "-std=c++11")
+ ei_add_test_sycl(cxx11_tensor_forced_eval_sycl "-std=c++11")
+ ei_add_test_sycl(cxx11_tensor_broadcast_sycl "-std=c++11")
+ ei_add_test_sycl(cxx11_tensor_device_sycl "-std=c++11")
+ endif(EIGEN_TEST_SYCL)
# It should be safe to always run these tests as there is some fallback code for
# older compiler that don't support cxx11.
set(CMAKE_CXX_STANDARD 11)
@@ -248,11 +254,3 @@ if(CUDA_FOUND AND EIGEN_TEST_CUDA)
unset(EIGEN_ADD_TEST_FILENAME_EXTENSION)
endif()
-
-
-if(EIGEN_TEST_SYCL)
- ei_add_test_sycl(cxx11_tensor_sycl "-std=c++11")
- ei_add_test_sycl(cxx11_tensor_forced_eval_sycl "-std=c++11")
- ei_add_test_sycl(cxx11_tensor_broadcast_sycl "-std=c++11")
- ei_add_test_sycl(cxx11_tensor_device_sycl "-std=c++11")
-endif(EIGEN_TEST_SYCL) \ No newline at end of file