aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-04-29 16:09:54 -0700
committerGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2016-04-29 16:09:54 -0700
commit4f53178e62f82b95c28ed67d507e6632515cfca6 (patch)
treef3f0ac9e5af1423daa8add93ab8085281ddb6f99 /unsupported/test/CMakeLists.txt
parent1131a984a67b3ed33333c3f253cd418a57c02f20 (diff)
Made a coupe of tensor tests compile without requiring c++11 support.
Diffstat (limited to 'unsupported/test/CMakeLists.txt')
-rw-r--r--unsupported/test/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/unsupported/test/CMakeLists.txt b/unsupported/test/CMakeLists.txt
index b9e1b34bf..485e4e1e0 100644
--- a/unsupported/test/CMakeLists.txt
+++ b/unsupported/test/CMakeLists.txt
@@ -110,12 +110,17 @@ ei_add_test(minres)
ei_add_test(levenberg_marquardt)
ei_add_test(kronecker_product)
+# TODO: The following tests are prefix with the cxx11 string, since historically
+# they depended on c++11. This isn't the case anymore so we ought to rename them.
+ei_add_test(cxx11_float16)
+ei_add_test(cxx11_tensor_forced_eval)
+
+
if(EIGEN_TEST_CXX11)
# It should be safe to always run these tests as there is some fallback code for
# older compiler that don't support cxx11.
set(CMAKE_CXX_STANDARD 11)
- ei_add_test(cxx11_float16)
ei_add_test(cxx11_eventcount "-pthread" "${CMAKE_THREAD_LIBS_INIT}")
ei_add_test(cxx11_runqueue "-pthread" "${CMAKE_THREAD_LIBS_INIT}")
ei_add_test(cxx11_meta)
@@ -130,7 +135,6 @@ if(EIGEN_TEST_CXX11)
ei_add_test(cxx11_tensor_convolution)
ei_add_test(cxx11_tensor_expr)
ei_add_test(cxx11_tensor_math)
- ei_add_test(cxx11_tensor_forced_eval)
ei_add_test(cxx11_tensor_fixed_size)
ei_add_test(cxx11_tensor_const)
ei_add_test(cxx11_tensor_of_const_values)