aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2018-10-19 17:20:51 +0200
committerGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2018-10-19 17:20:51 +0200
commit40fa6f98bf120b302c32be3fa15d7abbce4c96a7 (patch)
treec08382e868f605b5bddd3892f4d94c36bfd8f725 /unsupported/test/CMakeLists.txt
parentdda68f56eca13d6942ee9aabb0b6c55153802548 (diff)
bug #1606: Explicitly set the standard before find_package(StandardMathLibrary). Also replace EIGEN_COMPILER_SUPPORT_CXX11 in favor of EIGEN_COMPILER_SUPPORT_CPP11.
Diffstat (limited to 'unsupported/test/CMakeLists.txt')
-rw-r--r--unsupported/test/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/unsupported/test/CMakeLists.txt b/unsupported/test/CMakeLists.txt
index 875842272..cda658e0e 100644
--- a/unsupported/test/CMakeLists.txt
+++ b/unsupported/test/CMakeLists.txt
@@ -68,7 +68,7 @@ ei_add_test(EulerAngles)
find_package(MPFR 2.3.0)
find_package(GMP)
-if(MPFR_FOUND AND EIGEN_COMPILER_SUPPORT_CXX11)
+if(MPFR_FOUND AND EIGEN_COMPILER_SUPPORT_CPP11)
include_directories(${MPFR_INCLUDES} ./mpreal)
ei_add_property(EIGEN_TESTED_BACKENDS "MPFR C++, ")
set(EIGEN_MPFR_TEST_LIBRARIES ${MPFR_LIBRARIES} ${GMP_LIBRARIES})
@@ -151,8 +151,9 @@ if(EIGEN_TEST_CXX11)
else(EIGEN_SYCL_TRISYCL)
# It should be safe to always run these tests as there is some fallback code for
# older compiler that don't support cxx11.
- set(CMAKE_CXX_STANDARD 11)
- set(STD_CXX_FLAG "-std=c++11")
+ # This is already set if EIGEN_TEST_CXX11 is enabled:
+ # set(CMAKE_CXX_STANDARD 11)
+ # set(STD_CXX_FLAG "-std=c++11")
endif(EIGEN_SYCL_TRISYCL)
ei_add_test_sycl(cxx11_tensor_sycl ${STD_CXX_FLAG})