aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Mehdi Goli <mehdi.goli@codeplay.com>2016-12-14 15:30:37 +0000
committerGravatar Mehdi Goli <mehdi.goli@codeplay.com>2016-12-14 15:30:37 +0000
commit2d4a091beb9e55664c1475137af7166d524cbc1d (patch)
treed9e4baec0be3eb3c8a4bb2451701f7e49730daa1 /unsupported/test/CMakeLists.txt
parent3d59a477201d4d4f34b4332fda699c21387cf726 (diff)
Adding tensor contraction operation backend for Sycl; adding test for contractionOp sycl backend; adding temporary solution to prevent memory leak in buffer; cleaning up cxx11_tensor_buildins_sycl.h
Diffstat (limited to 'unsupported/test/CMakeLists.txt')
-rw-r--r--unsupported/test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unsupported/test/CMakeLists.txt b/unsupported/test/CMakeLists.txt
index 2fe03e24f..0405ee9fa 100644
--- a/unsupported/test/CMakeLists.txt
+++ b/unsupported/test/CMakeLists.txt
@@ -150,6 +150,7 @@ if(EIGEN_TEST_CXX11)
ei_add_test_sycl(cxx11_tensor_shuffling_sycl "-std=c++11")
ei_add_test_sycl(cxx11_tensor_padding_sycl "-std=c++11")
ei_add_test_sycl(cxx11_tensor_builtins_sycl "-std=c++11")
+ ei_add_test_sycl(cxx11_tensor_contract_sycl "-std=c++11")
endif(EIGEN_TEST_SYCL)
# It should be safe to always run these tests as there is some fallback code for
# older compiler that don't support cxx11.