aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/doc/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2009-03-18 20:06:06 +0000
committerGravatar Gael Guennebaud <g.gael@free.fr>2009-03-18 20:06:06 +0000
commit4bb5221d229703a906c6fe805b73fac2496c8bea (patch)
treef318f150d2051ce3d2c5912a6d243659e7bdc0c5 /unsupported/doc/examples/CMakeLists.txt
parent3d385ae9680fdd5093401ace8a5588444434d194 (diff)
Add BVH module in unsupported (patch from Ilya Baran)
(I thought I committed it a week ago but it seems the command failed)
Diffstat (limited to 'unsupported/doc/examples/CMakeLists.txt')
-rw-r--r--unsupported/doc/examples/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/unsupported/doc/examples/CMakeLists.txt b/unsupported/doc/examples/CMakeLists.txt
new file mode 100644
index 000000000..af4de4b0d
--- /dev/null
+++ b/unsupported/doc/examples/CMakeLists.txt
@@ -0,0 +1,17 @@
+FILE(GLOB examples_SRCS "*.cpp")
+
+ADD_CUSTOM_TARGET(unsupported_examples)
+
+FOREACH(example_src ${examples_SRCS})
+GET_FILENAME_COMPONENT(example ${example_src} NAME_WE)
+ADD_EXECUTABLE(${example} ${example_src})
+GET_TARGET_PROPERTY(example_executable
+ ${example} LOCATION)
+ADD_CUSTOM_COMMAND(
+ TARGET ${example}
+ POST_BUILD
+ COMMAND ${example_executable}
+ ARGS >${CMAKE_CURRENT_BINARY_DIR}/${example}.out
+)
+ADD_DEPENDENCIES(unsupported_examples ${example})
+ENDFOREACH(example_src)