aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/Eigen/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2016-08-29 10:59:37 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2016-08-29 10:59:37 +0200
commit35a8e945774581748dfe4a1993fbea71e6017102 (patch)
treea297cc4b2cbfcfd4ad0a672069ee4c44b460f8d2 /unsupported/Eigen/CMakeLists.txt
parent0decc31aa8238f88a6f2116907fb3e0a97ebaf23 (diff)
bug #1167: simplify installation of header files using cmake's install(DIRECTORY ...) command.
Diffstat (limited to 'unsupported/Eigen/CMakeLists.txt')
-rw-r--r--unsupported/Eigen/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/unsupported/Eigen/CMakeLists.txt b/unsupported/Eigen/CMakeLists.txt
index 7478b6b0d..67f3981dc 100644
--- a/unsupported/Eigen/CMakeLists.txt
+++ b/unsupported/Eigen/CMakeLists.txt
@@ -26,5 +26,6 @@ install(FILES
DESTINATION ${INCLUDE_INSTALL_DIR}/unsupported/Eigen COMPONENT Devel
)
-add_subdirectory(src)
+install(DIRECTORY src DESTINATION ${INCLUDE_INSTALL_DIR}/unsupported/Eigen COMPONENT Devel FILES_MATCHING PATTERN "*.h")
+
add_subdirectory(CXX11) \ No newline at end of file