aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar NeroBurner <pyro4hell@gmail.com>2017-01-02 09:09:21 +0100
committerGravatar NeroBurner <pyro4hell@gmail.com>2017-01-02 09:09:21 +0100
commitc4fc2611ba34652f98b5e0ac9f817879bef8eed1 (patch)
tree21c26eeb23304900f4d76ba955f7c0508750a076 /unsupported/CMakeLists.txt
parent45199b97730cc8f4773d7133478e3296b25c18ba (diff)
add cmake-option to enable/disable creation of tests
* * * disable unsupportet/test when test are disabled * * * rename EIGEN_ENABLE_TESTS to BUILD_TESTING * * * consider BUILD_TESTING in blas
Diffstat (limited to 'unsupported/CMakeLists.txt')
-rw-r--r--unsupported/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/unsupported/CMakeLists.txt b/unsupported/CMakeLists.txt
index 4fef40a86..9a5666105 100644
--- a/unsupported/CMakeLists.txt
+++ b/unsupported/CMakeLists.txt
@@ -1,7 +1,9 @@
add_subdirectory(Eigen)
add_subdirectory(doc EXCLUDE_FROM_ALL)
-if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
- add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
-else()
- add_subdirectory(test EXCLUDE_FROM_ALL)
+if(BUILD_TESTING)
+ if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
+ add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
+ else()
+ add_subdirectory(test EXCLUDE_FROM_ALL)
+ endif()
endif()