aboutsummaryrefslogtreecommitdiffhomepage
path: root/tvmet-1.7.1/testsuite/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2007-06-08 07:39:51 +0000
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2007-06-08 07:39:51 +0000
commitb155789aa7070659333a5ea629976ce9282bedbe (patch)
tree61f5bc61f0a2e8785414840c369e4cc853eebeed /tvmet-1.7.1/testsuite/CMakeLists.txt
parent681eb1ed7da6e73cf715fc043d0d15dbaf93d5e5 (diff)
begin porting the unittests to QTestLib. The first test, "selfTest"
already runs and succeeds. Also expand this test by testing more types and sizes.
Diffstat (limited to 'tvmet-1.7.1/testsuite/CMakeLists.txt')
-rw-r--r--tvmet-1.7.1/testsuite/CMakeLists.txt48
1 files changed, 24 insertions, 24 deletions
diff --git a/tvmet-1.7.1/testsuite/CMakeLists.txt b/tvmet-1.7.1/testsuite/CMakeLists.txt
index 045714dbc..f5ddf3a1a 100644
--- a/tvmet-1.7.1/testsuite/CMakeLists.txt
+++ b/tvmet-1.7.1/testsuite/CMakeLists.txt
@@ -9,30 +9,30 @@ FIND_PACKAGE(Qt4 REQUIRED)
INCLUDE_DIRECTORIES( ${QT_INCLUDE_DIR} )
SET(testsuite_SOURCES
- main.cc
- SelfTest.h SelfTest.cc
- TestNumericTraits.h TestNumericTraits.cc
- TestNumericTraitsComplex.h TestNumericTraitsComplex.cc
- TestConstruction.h TestConstruction.cc
- TestComplexMatrix.h TestComplexMatrix.cc
- TestComplexVector.h TestComplexVector.cc
- TestDimension.h TestDimension.cc
- TestMathOps.h TestMathOps.cc
- TestMatrixEval.h TestMatrixEval.cc
- TestMatrixFunctions.h TestMatrixFunctions.cc
- TestMatrixOperators.h TestMatrixOperators.cc
- TestSTL.h TestSTL.cc
- TestUnFunc.h TestUnFunc.cc
- TestVectorEval.h TestVectorEval.cc
- TestVectorFunctions.h TestVectorFunctions.cc
- TestVectorOperators.h TestVectorOperators.cc
- TestXpr.h TestXpr.cc
- TestXprMatrixFunctions.h TestXprMatrixFunctions.cc
- TestXprMatrixOperators.h TestXprMatrixOperators.cc
- TestXprVectorFunctions.h TestXprVectorFunctions.cc
- TestXprVectorOperators.h TestXprVectorOperators.cc
- TestUnloops.h TestUnloops.cc
- TestMatrixElementwise.h TestMatrixElementwise.cc
+ main.cpp
+ selftest.cpp
+# TestNumericTraits.h TestNumericTraits.cc
+# TestNumericTraitsComplex.h TestNumericTraitsComplex.cc
+# TestConstruction.h TestConstruction.cc
+# TestComplexMatrix.h TestComplexMatrix.cc
+# TestComplexVector.h TestComplexVector.cc
+# TestDimension.h TestDimension.cc
+# TestMathOps.h TestMathOps.cc
+# TestMatrixEval.h TestMatrixEval.cc
+# TestMatrixFunctions.h TestMatrixFunctions.cc
+# TestMatrixOperators.h TestMatrixOperators.cc
+# TestSTL.h TestSTL.cc
+# TestUnFunc.h TestUnFunc.cc
+# TestVectorEval.h TestVectorEval.cc
+# TestVectorFunctions.h TestVectorFunctions.cc
+# TestVectorOperators.h TestVectorOperators.cc
+# TestXpr.h TestXpr.cc
+# TestXprMatrixFunctions.h TestXprMatrixFunctions.cc
+# TestXprMatrixOperators.h TestXprMatrixOperators.cc
+# TestXprVectorFunctions.h TestXprVectorFunctions.cc
+# TestXprVectorOperators.h TestXprVectorOperators.cc
+# TestUnloops.h TestUnloops.cc
+# TestMatrixElementwise.h TestMatrixElementwise.cc
)
QT4_AUTOMOC(${testsuite_SOURCES})