aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar David Tellenbach <david.tellenbach@me.com>2020-08-19 18:27:45 +0000
committerGravatar David Tellenbach <david.tellenbach@me.com>2020-08-19 18:27:45 +0000
commitfe8c3ef3cbb9670335a8fdc31af552730baa8da2 (patch)
tree71e5872cf8150f5994a82d2fab4e1acf7ef2eb02 /test/CMakeLists.txt
parentd10b27fe37736d2944630ecd7557cefa95cf87c9 (diff)
Add possibility to split test suit build targets and improved CI configuration
- Introduce CMake option `EIGEN_SPLIT_TESTSUITE` that allows to divide the single test build target into several subtargets - Add CI pipeline for merge request that can be run by GitLab's shared runners - Add nightly CI pipeline
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6b2f4828d..013ad6cb3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -443,16 +443,11 @@ if (EIGEN_TEST_HIP)
message(FATAL_ERROR "HIP_PLATFORM = nvcc is not supported within Eigen")
else ()
message(FATAL_ERROR "Unknown HIP_PLATFORM = ${HIP_PLATFORM}")
- endif()
-
+ endif()
endif()
-
else ()
-
message(FATAL_ERROR "EIGEN_TEST_HIP is ON, but the specified HIP_PATH (${HIP_PATH}) does not exist")
-
endif()
-
endif()
option(EIGEN_TEST_BUILD_DOCUMENTATION "Test building the doxygen documentation" OFF)