aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2014-08-29 15:31:32 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2014-08-29 15:31:32 +0200
commitc1d0f15bde4614c3efb84248e5d2ceb9cb995779 (patch)
tree9ad0811d85d51d2e6709703f3758e82670bc793d /test/CMakeLists.txt
parent124d12a915129bc36ebe87f483712505a11dc91f (diff)
Enable evaluators by default
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6446b8bb0..075b8d3de 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -139,10 +139,10 @@ endif(TEST_LIB)
set_property(GLOBAL PROPERTY EIGEN_CURRENT_SUBPROJECT "Official")
add_custom_target(BuildOfficial)
-option(EIGEN_TEST_EVALUATORS "Enable work in progress evaluators" OFF)
-if(EIGEN_TEST_EVALUATORS)
- add_definitions("-DEIGEN_TEST_EVALUATORS=1")
-endif(EIGEN_TEST_EVALUATORS)
+option(EIGEN_TEST_NO_EVALUATORS "Disable evaluators in unit tests" OFF)
+if(EIGEN_TEST_NO_EVALUATORS)
+ add_definitions("-DEIGEN_TEST_NO_EVALUATORS=1")
+endif(EIGEN_TEST_NO_EVALUATORS)
ei_add_test(meta)
ei_add_test(sizeof)