aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2016-07-20 15:20:14 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2016-07-20 15:20:14 +0200
commitb64b9d017267b7a0e057a41171574e7dc9cd428b (patch)
treee4152d21408b1f895c98393cc841c792afc83e83 /test/CMakeLists.txt
parent5e4dda8a1201ada051fba9fc3cd0e645595238d5 (diff)
Add a unit test to stress our solvers with Boost.Multiprecision
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 27a9ec4ac..abc847794 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -327,6 +327,16 @@ if(EIGEN_TEST_EIGEN2)
message(WARNING "The Eigen2 test suite has been removed")
endif()
+# boost MP unit test
+find_package(Boost)
+if(Boost_FOUND)
+ include_directories(${Boost_INCLUDE_DIRS})
+ ei_add_test(boostmultiprec "" "${Boost_LIBRARIES}")
+ ei_add_property(EIGEN_TESTED_BACKENDS "Boost.Multiprecision, ")
+else()
+ ei_add_property(EIGEN_MISSING_BACKENDS "Boost.Multiprecision, ")
+endif()
+
# CUDA unit tests
option(EIGEN_TEST_CUDA "Enable CUDA support in unit tests" OFF)