aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2014-07-22 13:16:44 +0200
committerGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2014-07-22 13:16:44 +0200
commita8283e0ed2d3e42ba8e1c42f51cb08eacc301047 (patch)
treec9c78db74cdb680132a8779db69cf53ee73390ba /test/CMakeLists.txt
parent529e6cb5529f626b7c5cf781bdcd5a5720f904c1 (diff)
Define EIGEN_TRY, EIGEN_CATCH, EIGEN_THROW as suggested by Moritz Klammer.
Make it possible to run unit-tests with exceptions disabled via EIGEN_TEST_NO_EXCEPTIONS flag. Enhanced ctorleak unit-test
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index fed5c0e06..47aefddb8 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -158,7 +158,9 @@ ei_add_test(basicstuff)
ei_add_test(linearstructure)
ei_add_test(integer_types)
ei_add_test(unalignedcount)
-ei_add_test(exceptions)
+if(NOT EIGEN_TEST_NO_EXCEPTIONS)
+ ei_add_test(exceptions)
+endif()
ei_add_test(redux)
ei_add_test(visitor)
ei_add_test(block)
@@ -238,7 +240,9 @@ ei_add_test(nesting_ops "${CMAKE_CXX_FLAGS_DEBUG}")
ei_add_test(zerosized)
ei_add_test(dontalign)
ei_add_test(evaluators)
-ei_add_test(sizeoverflow)
+if(NOT EIGEN_TEST_NO_EXCEPTIONS)
+ ei_add_test(sizeoverflow)
+endif()
ei_add_test(prec_inverse_4x4)
ei_add_test(vectorwiseop)
ei_add_test(special_numbers)
@@ -251,8 +255,6 @@ ei_add_test(bicgstab)
ei_add_test(sparselu)
ei_add_test(sparseqr)
-ei_add_test(ctorleak)
-
# ei_add_test(denseLM)
if(QT4_FOUND)