aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-11-12 15:02:52 -0500
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-11-12 15:02:52 -0500
commit9b7708f6603555fa1f960d8f8ae30a3d613b478a (patch)
treea307c8e886a1d11a927c89c55a086e962e97e546 /test/CMakeLists.txt
parent8b563d7163d2e452468b8fdcec4900ecb2853213 (diff)
introduce check target, and some renaming
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5cea1a582..b074c8842 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,5 +1,9 @@
project(EigenTesting)
-add_custom_target(btest)
+add_custom_target(buildtests)
+add_custom_target(check COMMAND "ctest")
+add_dependencies(check buildtests)
+
+
include(EigenTesting)
ei_init_testing()
@@ -163,4 +167,4 @@ endif(CMAKE_COMPILER_IS_GNUCXX)
ei_add_property(EIGEN_TESTING_SUMMARY "CXX_FLAGS: ${CMAKE_CXX_FLAGS}\n")
ei_add_property(EIGEN_TESTING_SUMMARY "Sparse lib flags: ${SPARSE_LIBS}\n")
-configure_file(maketests.in ${CMAKE_BINARY_DIR}/maketests)
+configure_file(buildtests.in ${CMAKE_BINARY_DIR}/buildtests)