aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar David Tellenbach <david.tellenbach@me.com>2020-10-09 17:49:07 +0200
committerGravatar David Tellenbach <david.tellenbach@me.com>2020-10-09 17:49:07 +0200
commit7a8d3d5b81cb528f7f084b63686ffb20494053f6 (patch)
tree12b988cfe21c282fec5884f52524ed27d56d3466 /test/CMakeLists.txt
parent9022f5aa8aaf76cbe656050b78b74643fe95e9a5 (diff)
Disable test exceptions when using OpenMP.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 013ad6cb3..fa7634778 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -176,7 +176,7 @@ ei_add_test(constructor)
ei_add_test(linearstructure)
ei_add_test(integer_types)
ei_add_test(unalignedcount)
-if(NOT EIGEN_TEST_NO_EXCEPTIONS)
+if(NOT EIGEN_TEST_NO_EXCEPTIONS AND NOT EIGEN_TEST_OPENMP)
ei_add_test(exceptions)
endif()
ei_add_test(redux)