aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2014-04-12 23:39:37 -0700
committerGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2014-04-12 23:39:37 -0700
commit7903d3f27b275040702ce30eac8d329d6f571205 (patch)
tree7a144296e4d6ec012e30c06961df37cd390c44ec /test/CMakeLists.txt
parenta803ff18a963fc23ddb3dccf33ed7058af415f39 (diff)
Updated the compiler flags to enable nvcc to work with clang.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 62cbedae7..c2d827051 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -315,6 +315,9 @@ find_package(CUDA)
if(CUDA_FOUND)
set(CUDA_PROPAGATE_HOST_FLAGS OFF)
+ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ set(CUDA_NVCC_FLAGS "-ccbin /usr/bin/clang" CACHE STRING "nvcc flags" FORCE)
+ endif()
cuda_include_directories(${CMAKE_CURRENT_BINARY_DIR})
set(EIGEN_ADD_TEST_FILENAME_EXTENSION "cu")