aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2008-08-01 23:44:59 +0000
committerGravatar Gael Guennebaud <g.gael@free.fr>2008-08-01 23:44:59 +0000
commit55aeb1f83a5c303da09f5c5ef3037e75e71312cd (patch)
tree3fdcdc5a05f33a429b5090d1c979d67aeb4b8a7e /test/CMakeLists.txt
parentb32b186c14c7c9abdde1217d9d6b5b7d7cac532b (diff)
Optimizations:
* faster matrix-matrix and matrix-vector products (especially for not aligned cases) * faster tridiagonalization (make it using our matrix-vector impl.) Others: * fix Flags of Map * split the test_product to two smaller ones
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 14ed29a3d..97c7f4937 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -38,7 +38,12 @@ MACRO(EI_ADD_TEST testname)
SET(targetname test_${testname})
- ADD_EXECUTABLE(${targetname} ${testname}.cpp)
+ IF(${ARGC} EQUAL 2)
+ SET(filename ${ARGV1})
+ ELSE(${ARGC} EQUAL 2)
+ SET(filename ${testname}.cpp)
+ ENDIF(${ARGC} EQUAL 2)
+ ADD_EXECUTABLE(${targetname} ${filename})
IF(NOT EIGEN_NO_ASSERTION_CHECKING)
@@ -80,7 +85,8 @@ EI_ADD_TEST(nomalloc)
EI_ADD_TEST(basicstuff)
EI_ADD_TEST(linearstructure)
EI_ADD_TEST(cwiseop)
-EI_ADD_TEST(product)
+EI_ADD_TEST(product_small)
+EI_ADD_TEST(product_large)
EI_ADD_TEST(adjoint)
EI_ADD_TEST(submatrices)
EI_ADD_TEST(miscmatrices)