aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2019-02-20 14:43:05 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2019-02-20 14:43:05 +0100
commit44b54fa4a3618922e06abdca9c555b8697698237 (patch)
tree3d61d55a0d8bfd4d289eea0558d8636bfc834fec /test/CMakeLists.txt
parent7195f008ced2ec7fc8a1926d06b7cd797e9f3642 (diff)
Protect c++11 type alias with Eigen's macro, and add respective unit test.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 3dbb426eb..f74e22c28 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -164,6 +164,7 @@ ei_add_test(sizeof)
ei_add_test(dynalloc)
ei_add_test(nomalloc)
ei_add_test(first_aligned)
+ei_add_test(type_alias)
ei_add_test(nullary)
ei_add_test(mixingtypes)
ei_add_test(packetmath "-DEIGEN_FAST_MATH=1")