aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2018-07-17 00:11:20 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2018-07-17 00:11:20 +0200
commit40797dbea334405fb49ea1ba2cd972a23a7dbe02 (patch)
tree3727b1e9690f8e02971548db3f29c21c0537c19a /test/CMakeLists.txt
parentadd57574881f7389ce4a3f82934907420945b0f4 (diff)
bug #1572: use c++11 atomic instead of volatile if c++11 is available, and disable multi-threaded GEMM on non-x86 without c++11.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index aacfa22bb..b4730cff0 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -387,7 +387,6 @@ if(CUDA_FOUND)
if(EIGEN_TEST_CUDA_CLANG)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 --cuda-gpu-arch=sm_30")
endif()
- cuda_include_directories(${CMAKE_CURRENT_BINARY_DIR})
set(EIGEN_ADD_TEST_FILENAME_EXTENSION "cu")
ei_add_test(gpu_basic)
@@ -416,7 +415,6 @@ if (EIGEN_TEST_HIP)
if (${HIP_PLATFORM} STREQUAL "hcc")
- include_directories(${CMAKE_CURRENT_BINARY_DIR})
include_directories(${HIP_PATH}/include)
set(EIGEN_ADD_TEST_FILENAME_EXTENSION "cu")