aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2014-07-01 16:58:11 +0200
committerGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2014-07-01 16:58:11 +0200
commit324e7e8fc9a20503d3f7ee9969c886400bbf5786 (patch)
tree338a4d5ed1229df196d5520bfa026bc935e65027 /test/CMakeLists.txt
parent75e574275c97f8b2ab53c792c9fd886f32013b77 (diff)
Removed the deprecated EIGEN2_SUPPORT, as previously announced. A compilation error is raised, if this compile-switch is defined. The documentation references to the corresponding pages from Eigen3.2 now. Also, the Eigen2 testsuite has been removed.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index c2d827051..62c9c78a6 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -157,7 +157,6 @@ ei_add_test(vectorization_logic)
ei_add_test(basicstuff)
ei_add_test(linearstructure)
ei_add_test(integer_types)
-ei_add_test(cwiseop)
ei_add_test(unalignedcount)
ei_add_test(exceptions)
ei_add_test(redux)
@@ -258,8 +257,6 @@ if(QT4_FOUND)
ei_add_test(qtvector "" "${QT_QTCORE_LIBRARY}")
endif(QT4_FOUND)
-ei_add_test(eigen2support)
-
if(UMFPACK_FOUND)
ei_add_test(umfpack_support "" "${UMFPACK_ALL_LIBS}")
endif()
@@ -303,7 +300,7 @@ ei_add_property(EIGEN_TESTING_SUMMARY "Sparse lib flags: ${SPARSE_LIBS}\n")
option(EIGEN_TEST_EIGEN2 "Run whole Eigen2 test suite against EIGEN2_SUPPORT" OFF)
if(EIGEN_TEST_EIGEN2)
- add_subdirectory(eigen2)
+ message(WARNING "The Eigen2 test suite has been removed")
endif()