aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2015-03-27 16:36:59 +0100
committerGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2015-03-27 16:36:59 +0100
commit266a84558fe204d561df3071e280731d80e5fe4c (patch)
tree45a06608db66143b757109bd7cb66abdb08c1667 /test/CMakeLists.txt
parent1b4bb20cf1de4f224ac24173928d04685d92eb66 (diff)
Optionally build the documentation when building unit tests.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 393c35b57..54ce7fb30 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -332,3 +332,8 @@ endif(EIGEN_TEST_NVCC)
file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/failtests)
add_test(NAME failtests WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/failtests COMMAND ${CMAKE_COMMAND} ${Eigen_SOURCE_DIR} -G "${CMAKE_GENERATOR}" -DEIGEN_FAILTEST=ON)
+
+option(EIGEN_TEST_BUILD_DOCUMENTATION "Test building the doxygen documentation" OFF)
+IF(EIGEN_TEST_BUILD_DOCUMENTATION)
+ add_dependencies(buildtests doc)
+ENDIF()