aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Desire NUENTSA <desire.nuentsa_wakam@inria.fr>2012-03-08 18:59:08 +0100
committerGravatar Desire NUENTSA <desire.nuentsa_wakam@inria.fr>2012-03-08 18:59:08 +0100
commit0d8466d3178f8dc42d2bf7c55667468b94680864 (patch)
tree8f5e9a29c9395e0a81da4ad2f7a881055ee93b11 /test/CMakeLists.txt
parent37d2efd4f6a5efe5d0a15c6386aef8225ba3f27c (diff)
Adding an interface to PaStiX, the multithreaded and distributed linear solver
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 8569c8f9c..9ed11f601 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -53,6 +53,29 @@ else()
ei_add_property(EIGEN_MISSING_BACKENDS "SuperLU, ")
endif()
+
+find_package(Pastix)
+find_package(Scotch)
+find_package(Metis)
+if(PASTIX_FOUND AND BLAS_FOUND)
+ add_definitions("-DEIGEN_PASTIX_SUPPORT")
+ include_directories(${PASTIX_INCLUDES})
+ if(SCOTCH_FOUND)
+ include_directories(${SCOTCH_INCLUDES})
+ set(PASTIX_LIBRARIES ${PASTIX_LIBRARIES} ${SCOTCH_LIBRARIES})
+ elseif(METIS_FOUND)
+ include_directories(${METIS_INCLUDES})
+ set(PASTIX_LIBRARIES ${PASTIX_LIBRARIES} ${METIS_LIBRARIES})
+ else(SCOTCH_FOUND)
+ ei_add_property(EIGEN_MISSING_BACKENDS "PaStiX, ")
+ endif(SCOTCH_FOUND)
+ set(SPARSE_LIBS ${SPARSE_LIBS} ${PASTIX_LIBRARIES} ${ORDERING_LIBRARIES} ${BLAS_LIBRARIES})
+ set(PASTIX_ALL_LIBS ${PASTIX_LIBRARIES} ${BLAS_LIBRARIES})
+ ei_add_property(EIGEN_TESTED_BACKENDS "PaStiX, ")
+else()
+ ei_add_property(EIGEN_MISSING_BACKENDS "PaStiX, ")
+endif()
+
option(EIGEN_TEST_NOQT "Disable Qt support in unit tests" OFF)
if(NOT EIGEN_TEST_NOQT)
find_package(Qt4)
@@ -170,6 +193,7 @@ ei_add_test(simplicial_cholesky)
ei_add_test(conjugate_gradient)
ei_add_test(bicgstab)
+
if(UMFPACK_FOUND)
ei_add_test(umfpack_support "" "${UMFPACK_ALL_LIBS}")
endif()
@@ -186,6 +210,10 @@ if(PARDISO_FOUND)
ei_add_test(pardiso_support "" "${PARDISO_ALL_LIBS}")
endif()
+if(PASTIX_FOUND AND (SCOTCH_FOUND OR METIS_FOUND))
+ ei_add_test(pastix_support "" "${PASTIX_ALL_LIBS}")
+endif()
+
string(TOLOWER "${CMAKE_CXX_COMPILER}" cmake_cxx_compiler_tolower)
if(cmake_cxx_compiler_tolower MATCHES "qcc")
set(CXX_IS_QCC "ON")