aboutsummaryrefslogtreecommitdiffhomepage
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-11-25 21:26:37 -0500
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-11-25 21:26:37 -0500
commit5923bcb1b94cd5a79dfc57f2ffe6271d999ea67d (patch)
tree8b4d720e2e271a1d22b7d1eb3435846b284ec952 /scripts/CMakeLists.txt
parentf795681da0fec9cd8a56f6987c903ec9a530d509 (diff)
improve the scripts for building unit tests:
* support unsupported/ * use egrep instead of grep, properly escape special chars.
Diffstat (limited to 'scripts/CMakeLists.txt')
-rw-r--r--scripts/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
index b75e99d5e..acf3bb6e9 100644
--- a/scripts/CMakeLists.txt
+++ b/scripts/CMakeLists.txt
@@ -1,3 +1,6 @@
+get_property(EIGEN_TESTS_LIST GLOBAL PROPERTY EIGEN_TESTS_LIST)
+configure_file(buildtests.in ${CMAKE_BINARY_DIR}/buildtests)
+
configure_file(check.in ${CMAKE_BINARY_DIR}/check)
configure_file(debug.in ${CMAKE_BINARY_DIR}/debug)
configure_file(release.in ${CMAKE_BINARY_DIR}/release)