aboutsummaryrefslogtreecommitdiffhomepage
path: root/failtest/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar David Tellenbach <david.tellenbach@tellnotes.org>2019-01-21 16:25:57 +0100
committerGravatar David Tellenbach <david.tellenbach@tellnotes.org>2019-01-21 16:25:57 +0100
commitdb152b9ee6effd3799f70a621f495c427cb3c33f (patch)
tree25a9c96f0cdfbed28072ea7e2f8602412ce6de7f /failtest/CMakeLists.txt
parent543529da6a1eabf415f4f8b56495fad76b57ba22 (diff)
PR 572: Add initializer list constructors to Matrix and Array (include unit tests and doc)
- {1,2,3,4,5,...} for fixed-size vectors only - {{1,2,3},{4,5,6}} for the general cases - {{1,2,3,4,5,....}} is allowed for both row and column-vector
Diffstat (limited to 'failtest/CMakeLists.txt')
-rw-r--r--failtest/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/failtest/CMakeLists.txt b/failtest/CMakeLists.txt
index f95503d7e..256e541e2 100644
--- a/failtest/CMakeLists.txt
+++ b/failtest/CMakeLists.txt
@@ -63,3 +63,8 @@ ei_add_failtest("bdcsvd_int")
ei_add_failtest("eigensolver_int")
ei_add_failtest("eigensolver_cplx")
+if(EIGEN_TEST_CXX11)
+ ei_add_failtest("initializer_list_1")
+ ei_add_failtest("initializer_list_2")
+endif()
+