aboutsummaryrefslogtreecommitdiffhomepage
path: root/failtest/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2014-11-05 16:15:17 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2014-11-05 16:15:17 +0100
commitc6fefe5d8e3eda8af05c7dcb278551598dbb5d8e (patch)
tree75b00f017c2ca94dd79dc3798e67ed3853425d20 /failtest/CMakeLists.txt
parentee06f786797b74e75e6c2eae1209fa6389c49876 (diff)
Big 853: replace enable_if in Ref<> ctor by static assertions and add failtests for Ref<>
Diffstat (limited to 'failtest/CMakeLists.txt')
-rw-r--r--failtest/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/failtest/CMakeLists.txt b/failtest/CMakeLists.txt
index 83b6c81a9..5343dc152 100644
--- a/failtest/CMakeLists.txt
+++ b/failtest/CMakeLists.txt
@@ -32,6 +32,12 @@ ei_add_failtest("cwiseunaryview_on_const_type_actually_const")
ei_add_failtest("triangularview_on_const_type_actually_const")
ei_add_failtest("selfadjointview_on_const_type_actually_const")
+ei_add_failtest("ref_1")
+ei_add_failtest("ref_2")
+ei_add_failtest("ref_3")
+ei_add_failtest("ref_4")
+ei_add_failtest("ref_5")
+
if (EIGEN_FAILTEST_FAILURE_COUNT)
message(FATAL_ERROR
"${EIGEN_FAILTEST_FAILURE_COUNT} out of ${EIGEN_FAILTEST_COUNT} failtests FAILED. "