aboutsummaryrefslogtreecommitdiffhomepage
path: root/failtest/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2011-02-05 18:57:29 -0500
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2011-02-05 18:57:29 -0500
commit9b13e9aeceffd56fb1560a8aef51079ae65f13c4 (patch)
tree15ae653c7db613570d8e3b9c40b2737cb04d70fd /failtest/CMakeLists.txt
parent8aee724274ea4d70f926c544cf57e706c61a3e82 (diff)
failtest: a new cmake-based test suite for testing stuff that should fail to build. This first batch imports some const correctness checks from bug #54.
Diffstat (limited to 'failtest/CMakeLists.txt')
-rw-r--r--failtest/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/failtest/CMakeLists.txt b/failtest/CMakeLists.txt
new file mode 100644
index 000000000..424ce1795
--- /dev/null
+++ b/failtest/CMakeLists.txt
@@ -0,0 +1,17 @@
+message(STATUS "Running the failtests")
+
+ei_add_failtest("failtest_sanity_check")
+ei_add_failtest("block_nonconst_ctor_on_const_xpr_0")
+ei_add_failtest("block_nonconst_ctor_on_const_xpr_1")
+ei_add_failtest("block_nonconst_ctor_on_const_xpr_2")
+ei_add_failtest("transpose_nonconst_ctor_on_const_xpr")
+ei_add_failtest("diagonal_nonconst_ctor_on_const_xpr")
+
+if (EIGEN_FAILTEST_FAILURE_COUNT)
+ message(FATAL_ERROR "${EIGEN_FAILTEST_FAILURE_COUNT} out of ${EIGEN_FAILTEST_COUNT} failtests FAILED. "
+ "Failtests succeed when they generate build errors. "
+ "To debug these failures, manually compile these programs in ${CMAKE_CURRENT_SOURCE_DIR}.")
+else()
+ message(STATUS "Failtest SUCCESS: all ${EIGEN_FAILTEST_COUNT} failtests passed.")
+ message(STATUS "")
+endif()