aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/special_examples/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2014-01-07 20:23:35 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2014-01-07 20:23:35 +0100
commit92190a1cafc3a8613e1200cd4ed81dbc509a93bd (patch)
tree43084ae6898fa9bd36e5d71363cc8dcdf8ca0a6c /doc/special_examples/CMakeLists.txt
parentac409f51f185a4654f9a5c38ab5d1652824836f6 (diff)
Add an example showing how to use C++11 random distributions
Diffstat (limited to 'doc/special_examples/CMakeLists.txt')
-rw-r--r--doc/special_examples/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/doc/special_examples/CMakeLists.txt b/doc/special_examples/CMakeLists.txt
index 0c9b3c3ba..45e2339e3 100644
--- a/doc/special_examples/CMakeLists.txt
+++ b/doc/special_examples/CMakeLists.txt
@@ -19,3 +19,22 @@ if(QT4_FOUND)
add_dependencies(all_examples Tutorial_sparse_example)
endif(QT4_FOUND)
+
+check_cxx_compiler_flag("-std=c++11" EIGEN_COMPILER_SUPPORT_CPP11)
+if(EIGEN_COMPILER_SUPPORT_CPP11)
+ add_executable(random_cpp11 random_cpp11.cpp)
+ target_link_libraries(random_cpp11 ${EIGEN_STANDARD_LIBRARIES_TO_LINK_TO})
+ add_dependencies(all_examples random_cpp11)
+ ei_add_target_property(random_cpp11 COMPILE_FLAGS "-std=c++11")
+
+ get_target_property(random_cpp11_exec
+ random_cpp11 LOCATION)
+ add_custom_command(
+ TARGET random_cpp11
+ POST_BUILD
+ COMMAND ${random_cpp11_exec}
+ ARGS >${CMAKE_CURRENT_BINARY_DIR}/random_cpp11.out
+ )
+
+
+endif() \ No newline at end of file