aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/snippets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2009-02-04 09:44:44 +0000
committerGravatar Gael Guennebaud <g.gael@free.fr>2009-02-04 09:44:44 +0000
commit44a527dfa50ce9c473cbf1f446b8b6f406d4bc91 (patch)
treea0f045d2a4c22a38e08e1b1d1ce0e17e630898c7 /doc/snippets/CMakeLists.txt
parentb0dd22cc7271523ba83d2bc8a85504b8445587b5 (diff)
* classify and sort the doxygen "related pages"
by tweaking the filename and adding 2 categories: Troubleshooting and Advanced * use the EXCLUDE_SYMBOLS to clean the class list (insteaded of a homemade bash script) * remove the broken "exemple list" * re-structure the unsupported directory as mentionned in the ML and integrate the doc as follow: - snippets of the unsupported directory are directly imported from the main snippets/CMakefile.txt (no need to duplicate code) - add a top level "Unsupported modules" group - unsupported modules have to defined their own sub group and nest it using \ingroup Unsupported_modules - then a pair of //@{ //@} will put everything in the submodule - this is just a proposal !
Diffstat (limited to 'doc/snippets/CMakeLists.txt')
-rw-r--r--doc/snippets/CMakeLists.txt40
1 files changed, 20 insertions, 20 deletions
diff --git a/doc/snippets/CMakeLists.txt b/doc/snippets/CMakeLists.txt
index 72bd7770a..195ed9e99 100644
--- a/doc/snippets/CMakeLists.txt
+++ b/doc/snippets/CMakeLists.txt
@@ -1,25 +1,25 @@
-FILE(GLOB snippets_SRCS "*.cpp")
+FILE(GLOB snippets_SRCS "*.cpp" "../../unsupported/snippets/*.cpp")
ADD_CUSTOM_TARGET(all_snippets)
FOREACH(snippet_src ${snippets_SRCS})
-GET_FILENAME_COMPONENT(snippet ${snippet_src} NAME_WE)
-SET(compile_snippet_target compile_${snippet})
-SET(compile_snippet_src ${compile_snippet_target}.cpp)
-FILE(READ ${snippet_src} snippet_source_code)
-CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/compile_snippet.cpp.in
- ${CMAKE_CURRENT_BINARY_DIR}/${compile_snippet_src})
-ADD_EXECUTABLE(${compile_snippet_target}
- ${CMAKE_CURRENT_BINARY_DIR}/${compile_snippet_src})
-GET_TARGET_PROPERTY(compile_snippet_executable
- ${compile_snippet_target} LOCATION)
-ADD_CUSTOM_COMMAND(
- TARGET ${compile_snippet_target}
- POST_BUILD
- COMMAND ${compile_snippet_executable}
- ARGS >${CMAKE_CURRENT_BINARY_DIR}/${snippet}.out
-)
-ADD_DEPENDENCIES(all_snippets ${compile_snippet_target})
-set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${compile_snippet_src}
- PROPERTIES OBJECT_DEPENDS ${snippet_src})
+ GET_FILENAME_COMPONENT(snippet ${snippet_src} NAME_WE)
+ SET(compile_snippet_target compile_${snippet})
+ SET(compile_snippet_src ${compile_snippet_target}.cpp)
+ FILE(READ ${snippet_src} snippet_source_code)
+ CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/compile_snippet.cpp.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${compile_snippet_src})
+ ADD_EXECUTABLE(${compile_snippet_target}
+ ${CMAKE_CURRENT_BINARY_DIR}/${compile_snippet_src})
+ GET_TARGET_PROPERTY(compile_snippet_executable
+ ${compile_snippet_target} LOCATION)
+ ADD_CUSTOM_COMMAND(
+ TARGET ${compile_snippet_target}
+ POST_BUILD
+ COMMAND ${compile_snippet_executable}
+ ARGS >${CMAKE_CURRENT_BINARY_DIR}/${snippet}.out
+ )
+ ADD_DEPENDENCIES(all_snippets ${compile_snippet_target})
+ set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${compile_snippet_src}
+ PROPERTIES OBJECT_DEPENDS ${snippet_src})
ENDFOREACH(snippet_src)