aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2016-09-22 22:27:54 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2016-09-22 22:27:54 +0200
commit9bcdc8b75669d2a2ec3a7e1fe6ae96854a0bc2e4 (patch)
tree2eed12553abe0217ec1b551624224e22bf6844b9 /doc/examples/CMakeLists.txt
parentca3746c6f8f788e4cc6ad9c88d1857c85be19a3b (diff)
Add a nullary-functor example performing index-based sub-matrices.
Diffstat (limited to 'doc/examples/CMakeLists.txt')
-rw-r--r--doc/examples/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/doc/examples/CMakeLists.txt b/doc/examples/CMakeLists.txt
index 08cf8efd7..f7a19055f 100644
--- a/doc/examples/CMakeLists.txt
+++ b/doc/examples/CMakeLists.txt
@@ -14,3 +14,8 @@ foreach(example_src ${examples_SRCS})
)
add_dependencies(all_examples ${example})
endforeach(example_src)
+
+check_cxx_compiler_flag("-std=c++11" EIGEN_COMPILER_SUPPORT_CPP11)
+if(EIGEN_COMPILER_SUPPORT_CPP11)
+ei_add_target_property(nullary_indexing COMPILE_FLAGS "-std=c++11")
+endif() \ No newline at end of file