aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2008-05-28 04:38:16 +0000
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2008-05-28 04:38:16 +0000
commitaebecae510dd29f5573d3f86dfed526e6d8be9a8 (patch)
treeb9bb9d2d15011409fe5f66e1fbb56f1998f5cc91 /doc/CMakeLists.txt
parent559233c73e86474d67f5730f9b20e46ccea93b7f (diff)
* find the proper way of nesting the expression in Flagged:
finally that's more subtle than just using ei_nested, because when flagging with NestByValueBit we want to store the expression by value already, regardless of whether it already had the NestByValueBit set. * rename temporary() ----> nestByValue() * move the old Product.h to disabled/, replace by what was ProductWIP.h * tweak -O and -g flags for tests and examples * reorder the tests -- basic things go first * simplifications, e.g. in many methoeds return derived() and count on implicit casting to the actual return type. * strip some not-really-useful stuff from the heaviest tests
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 39af38afe..4e1a7696d 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -1,5 +1,11 @@
IF(BUILD_DOC)
+IF(CMAKE_COMPILER_IS_GNUCXX)
+ IF(CMAKE_SYSTEM_NAME MATCHES Linux)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O1 -g1")
+ ENDIF(CMAKE_SYSTEM_NAME MATCHES Linux)
+ENDIF(CMAKE_COMPILER_IS_GNUCXX)
+
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in
${CMAKE_CURRENT_BINARY_DIR}/Doxyfile