aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2018-10-08 17:32:54 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2018-10-08 17:32:54 +0200
commitaa5820056ec1a21b23c716b2b6519c16f9fe4d04 (patch)
treed39f75bf9af583be241c96aa30561d71c08bcd51 /doc/CMakeLists.txt
parente21766c6f585e833aa7e4c02f3d50d7d276c0fd4 (diff)
Unify c++11 usage in doc's examples and snippets
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index db413bc65..9f6730b9c 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -10,6 +10,9 @@ if(CMAKE_COMPILER_IS_GNUCXX)
endif(CMAKE_SYSTEM_NAME MATCHES Linux)
endif(CMAKE_COMPILER_IS_GNUCXX)
+# some examples and snippets needs c++11, so let's check it once
+check_cxx_compiler_flag("-std=c++11" EIGEN_COMPILER_SUPPORT_CPP11)
+
option(EIGEN_INTERNAL_DOCUMENTATION "Build internal documentation" OFF)