aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2007-12-21 09:30:32 +0000
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2007-12-21 09:30:32 +0000
commita316cd8a76e13927038cad67cdc436fb32921839 (patch)
tree2c49c0122bd2a63c676f3a9b1d63fc0b200bfe69 /doc/CMakeLists.txt
parentee3410f79a05ada2f508e1cb96bf4896ba369d6c (diff)
now cmake takes snippets of code, completes them into compilable sources, builds them,
executes them and stores their output in files.
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 265bbbec1..ba8798e9c 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -1,6 +1,10 @@
+IF(BUILD_DOC)
+
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in
${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
)
-ADD_SUBDIRECTORY(examples)
+ADD_SUBDIRECTORY(snippets)
+
+ENDIF(BUILD_DOC)