aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2013-01-05 16:37:11 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2013-01-05 16:37:11 +0100
commit93ee82b1fda6d395d1f70d7fb767b5dceaf4ca29 (patch)
tree21de49e996afa6db673dcff8757ed7bbbb0bf587 /doc/CMakeLists.txt
parenteac676ff6cf3f9c2d4a11e92e7211e7d763e8d6f (diff)
Big changes in Eigen documentation:
- Organize the documentation into "chapters". - Each chapter include many documentation pages, reference pages organized as modules, and a quick reference page. - The "Chapters" tree is created using the defgroup/ingroup mechanism, even for the documentation pages (i.e., .dox files for which I added an \eigenManualPage macro that we can switch between \page or \defgroup ). - Add a "General topics" entry for all pages that do not fit well in the previous "chapters". - The highlevel struture is managed by a new eigendoxy_layout.xml file. - remove the "index" and quite useless pages (namespace list, class hierarchy, member list, file list, etc.) - add the javascript search-engine. - add the "treeview" panel. - remove \tableofcontents (replace them by a custom \eigenAutoToc macro to be able to easily re-enable if needed). - add javascript to automatically generate a TOC from the h1/h2 tags of the current page, and put the TOC in the left side panel. - overload various javascript function generated by doxygen to: - remove the root of the treeview - remove links to section/subsection from the treeview - automatically expand the "Chapters" section - automatically expand the current section - adjust the height of the treeview to take into account the TOC - always use the default .css file, eigendoxy.css now only includes our modifications - use Doxyfile to specify our logo - remove cross references to unsupported modules (temporarily)
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 33bc1d45d..d932ff3cc 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -30,6 +30,11 @@ configure_file(
${CMAKE_CURRENT_BINARY_DIR}/eigendoxy_footer.html
)
+configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/eigendoxy_layout.xml.in
+ ${CMAKE_CURRENT_BINARY_DIR}/eigendoxy_layout.xml
+)
+
set(examples_targets "")
set(snippets_targets "")
@@ -44,7 +49,7 @@ add_custom_target(
doc-eigen-prerequisites
ALL
COMMAND ${CMAKE_COMMAND} -E make_directory ${CMAKE_CURRENT_BINARY_DIR}/html/
- COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_SOURCE_DIR}/eigendoxy_tabs.css
+ COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_SOURCE_DIR}/eigen_navtree_hacks.js
${CMAKE_CURRENT_BINARY_DIR}/html/
COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_SOURCE_DIR}/Eigen_Silly_Professor_64x64.png
${CMAKE_CURRENT_BINARY_DIR}/html/