aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hauke Heibel <hauke.heibel@gmail.com>2009-05-17 12:12:39 +0200
committerGravatar Hauke Heibel <hauke.heibel@gmail.com>2009-05-17 12:12:39 +0200
commit6ea7cbdc8703775a5419bcb003a8d8a29fc3b671 (patch)
tree3414b6de5272787b44dd3484829938a98bbdd28c /doc/CMakeLists.txt
parent36c9c2597f11edc7bc738c1d2e27944838e54200 (diff)
* added missing project definition (see doc of add_subdirectory and EXCLUDE_FROM_ALL) to fix a win build issue
* commented out non-existing unsupported-snippets and -examples
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 7aabe2882..773866306 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -1,6 +1,8 @@
set_directory_properties(PROPERTIES EXCLUDE_FROM_ALL TRUE)
+project(EigenDoc)
+
if(CMAKE_COMPILER_IS_GNUCXX)
if(CMAKE_SYSTEM_NAME MATCHES Linux)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O1 -g1")
@@ -60,7 +62,7 @@ add_custom_target(
)
add_dependencies(doc-eigen-prerequisites all_snippets all_examples)
-add_dependencies(doc-unsupported-prerequisites unsupported_snippets unsupported_examples)
+# add_dependencies(doc-unsupported-prerequisites unsupported_snippets unsupported_examples)
add_custom_target(doc ALL
COMMAND doxygen Doxyfile-unsupported
COMMAND doxygen