aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Martin Vonheim Larsen <6857165-martinvl@users.noreply.gitlab.com>2020-11-16 12:59:13 +0000
committerGravatar David Tellenbach <david.tellenbach@me.com>2020-11-16 12:59:13 +0000
commit280f4f2407ffdf93488de7e95ca6e31fff770f21 (patch)
treee6ec5d8361d16be239ce5f4e61dedc16ec9bf23a /doc/CMakeLists.txt
parentbb69a8db5da21f3c6b289d010eaa64e757387dca (diff)
Enable MathJax in Doxygen.in
Note that HTTPS must be used against the MathJax CDN when hosted on `eigen.tuxfamily.org` (which uses HTTPS) in order to avoid `Mixed Content`-errors from browsers. Using HTTPS for MathJax also works if the Eigen docs are hosted on plain HTTP.
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 50ae9ea47..0f9ef2382 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -14,7 +14,7 @@ endif()
check_cxx_compiler_flag("-std=c++11" EIGEN_COMPILER_SUPPORT_CPP11)
option(EIGEN_INTERNAL_DOCUMENTATION "Build internal documentation" OFF)
-
+option(EIGEN_DOC_USE_MATHJAX "Use MathJax for rendering math in HTML docs" ON)
# Set some Doxygen flags
set(EIGEN_DOXY_PROJECT_NAME "Eigen")
@@ -22,12 +22,19 @@ set(EIGEN_DOXY_OUTPUT_DIRECTORY_SUFFIX "")
set(EIGEN_DOXY_INPUT "\"${Eigen_SOURCE_DIR}/Eigen\" \"${Eigen_SOURCE_DIR}/doc\"")
set(EIGEN_DOXY_HTML_COLORSTYLE_HUE "220")
set(EIGEN_DOXY_TAGFILES "")
+
if(EIGEN_INTERNAL_DOCUMENTATION)
set(EIGEN_DOXY_INTERNAL "YES")
else()
set(EIGEN_DOXY_INTERNAL "NO")
endif()
+if (EIGEN_DOC_USE_MATHJAX)
+ set(EIGEN_DOXY_USE_MATHJAX "YES")
+else ()
+ set(EIGEN_DOXY_USE_MATHJAX "NO")
+endif()
+
configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in
${CMAKE_CURRENT_BINARY_DIR}/Doxyfile