aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2014-07-18 14:34:58 +0200
committerGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2014-07-18 14:34:58 +0200
commit1cb71a8782c5aa8d75562ebf2c36d1581e7799ef (patch)
tree6ea1a4da642823c9bb80e0a847216ea3298ec89b /doc/CMakeLists.txt
parentac1bb3e5b3349bf744c3905fec55295e6bb024ab (diff)
bug #138: Make building of internal documentation configurable via cmake flag
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 8a493031c..1b8aaf9aa 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -10,12 +10,20 @@ if(CMAKE_COMPILER_IS_GNUCXX)
endif(CMAKE_SYSTEM_NAME MATCHES Linux)
endif(CMAKE_COMPILER_IS_GNUCXX)
+option(EIGEN_INTERNAL_DOCUMENTATION "Build internal documentation" OFF)
+
+
# Set some Doxygen flags
set(EIGEN_DOXY_PROJECT_NAME "Eigen")
set(EIGEN_DOXY_OUTPUT_DIRECTORY_SUFFIX "")
set(EIGEN_DOXY_INPUT "\"${Eigen_SOURCE_DIR}/Eigen\" \"${Eigen_SOURCE_DIR}/doc\"")
set(EIGEN_DOXY_HTML_COLORSTYLE_HUE "220")
set(EIGEN_DOXY_TAGFILES "")
+if(EIGEN_INTERNAL_DOCUMENTATION)
+ set(EIGEN_DOXY_INTERNAL "YES")
+else(EIGEN_INTERNAL_DOCUMENTATION)
+ set(EIGEN_DOXY_INTERNAL "NO")
+endif(EIGEN_INTERNAL_DOCUMENTATION)
configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in