aboutsummaryrefslogtreecommitdiffhomepage
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2007-12-21 09:02:24 +0000
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2007-12-21 09:02:24 +0000
commit04e3512eb67259f0e8e39de16ac91af36c3f21f1 (patch)
treed688441a0eea006cebf832d33a88346c170a0d3c /doc/CMakeLists.txt
parent64f5d5d318d6eafc0ac91e3f4f904b53db86c54f (diff)
first version of CMakeLists auto-generating examples outputs
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 66b259498..265bbbec1 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -1,4 +1,6 @@
-FILE(GLOB examples "*.cpp")
-
-FOREACH(example examples)
+CONFIGURE_FILE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in
+ ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
+)
+ADD_SUBDIRECTORY(examples)