aboutsummaryrefslogtreecommitdiffhomepage
path: root/demos/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-09-27 17:48:53 -0400
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-09-27 17:48:53 -0400
commit92480ffd265475a25070b8ea9dfbc8536d038378 (patch)
tree2beb82f3c944172e3c713b4ccdeb70cbea84f23d /demos/CMakeLists.txt
parent6b23cb210144683351f94d43c99106b71ce8393d (diff)
* Introduce make targets btest (build tests), blas (build blas lib), demos (build demos).
* remove EIGEN_BUILD_TESTS and siblings * add summary at the end of cmake run, hopefully not too verbose * fix build of quaternion demo * kill remnants of old binary library option
Diffstat (limited to 'demos/CMakeLists.txt')
-rw-r--r--demos/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/demos/CMakeLists.txt b/demos/CMakeLists.txt
index 4e8f5164f..1ec49d13e 100644
--- a/demos/CMakeLists.txt
+++ b/demos/CMakeLists.txt
@@ -1,3 +1,9 @@
+add_custom_target(demos)
-add_subdirectory(mandelbrot)
-add_subdirectory(opengl)
+find_package(Qt4)
+if(QT4_FOUND)
+ add_subdirectory(mandelbrot)
+ add_subdirectory(opengl)
+else(QT4_FOUND)
+ message(STATUS "Qt4 not found, so disabling the mandelbrot and opengl demos")
+endif(QT4_FOUND)