aboutsummaryrefslogtreecommitdiffhomepage
path: root/blas/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2010-11-22 18:05:09 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2010-11-22 18:05:09 +0100
commita6f483e86b0c4c1d82622eec99fb051c804bf13d (patch)
treeade493273b163904264c03585e749cfd24ab1a38 /blas/CMakeLists.txt
parent7213dd1e6bbdcc0991be095deb85387d3c57dd17 (diff)
import reference BLAS routines which are not already implemented in Eigen : modified givens rotations, and packed and banded storages
Diffstat (limited to 'blas/CMakeLists.txt')
-rw-r--r--blas/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/blas/CMakeLists.txt b/blas/CMakeLists.txt
index 8c8034294..78b5f496c 100644
--- a/blas/CMakeLists.txt
+++ b/blas/CMakeLists.txt
@@ -15,7 +15,10 @@ endif()
add_custom_target(blas)
-set(EigenBlas_SRCS single.cpp double.cpp complex_single.cpp complex_double.cpp xerbla.cpp)
+set(EigenBlas_SRCS single.cpp double.cpp complex_single.cpp complex_double.cpp xerbla.cpp
+ srotm.f srotmg.f drotm.f drotmg.f
+ lsame.f cgbmv.f chpr2.f ctbsv.f dspmv.f dtbmv.f dtpsv.f ssbmv.f sspr.f stpmv.f zgbmv.f zhpr2.f ztbsv.f chbmv.f chpr.f ctpmv.f dgbmv.f dspr2.f dtbsv.f sspmv.f stbmv.f stpsv.f zhbmv.f zhpr.f ztpmv.f chpmv.f ctbmv.f ctpsv.f dsbmv.f dspr.f dtpmv.f sgbmv.f sspr2.f stbsv.f zhpmv.f ztbmv.f ztpsv.f
+)
add_library(eigen_blas_static ${EigenBlas_SRCS})
add_library(eigen_blas SHARED ${EigenBlas_SRCS})