aboutsummaryrefslogtreecommitdiffhomepage
path: root/blas/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-09-27 17:48:53 -0400
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-09-27 17:48:53 -0400
commit92480ffd265475a25070b8ea9dfbc8536d038378 (patch)
tree2beb82f3c944172e3c713b4ccdeb70cbea84f23d /blas/CMakeLists.txt
parent6b23cb210144683351f94d43c99106b71ce8393d (diff)
* Introduce make targets btest (build tests), blas (build blas lib), demos (build demos).
* remove EIGEN_BUILD_TESTS and siblings * add summary at the end of cmake run, hopefully not too verbose * fix build of quaternion demo * kill remnants of old binary library option
Diffstat (limited to 'blas/CMakeLists.txt')
-rw-r--r--blas/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/blas/CMakeLists.txt b/blas/CMakeLists.txt
index 477693bad..65ef77c90 100644
--- a/blas/CMakeLists.txt
+++ b/blas/CMakeLists.txt
@@ -1,7 +1,9 @@
+add_custom_target(blas)
set(EigenBlas_SRCS single.cpp double.cpp complex_single.cpp complex_double.cpp)
add_library(eigen_blas SHARED ${EigenBlas_SRCS})
+add_dependencies(blas eigen_blas)
install(TARGETS eigen_blas
RUNTIME DESTINATION bin