aboutsummaryrefslogtreecommitdiffhomepage
path: root/blas/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2010-04-19 11:19:22 -0400
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2010-04-19 11:19:22 -0400
commit84d1b2ae3a7187f418b1cbbec03eabda372ea699 (patch)
tree2a62b619ec3e5299edfcf3b7e4a184670ff3e29a /blas/CMakeLists.txt
parent40b2aaa8b149403a8f345f1f7721ddd6088db669 (diff)
add platform check for how to link to the standard math library.
This allows to support QNX.
Diffstat (limited to 'blas/CMakeLists.txt')
-rw-r--r--blas/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/blas/CMakeLists.txt b/blas/CMakeLists.txt
index d1f5b5676..a752d2ea2 100644
--- a/blas/CMakeLists.txt
+++ b/blas/CMakeLists.txt
@@ -6,6 +6,12 @@ set(EigenBlas_SRCS single.cpp double.cpp complex_single.cpp complex_double.cpp x
add_library(eigen_blas_static ${EigenBlas_SRCS})
add_library(eigen_blas SHARED ${EigenBlas_SRCS})
+
+if(EIGEN_STANDARD_LIBRARIES_TO_LINK_TO)
+ target_link_libraries(eigen_blas_static ${EIGEN_STANDARD_LIBRARIES_TO_LINK_TO})
+ target_link_libraries(eigen_blas ${EIGEN_STANDARD_LIBRARIES_TO_LINK_TO})
+endif()
+
add_dependencies(blas eigen_blas eigen_blas_static)
install(TARGETS eigen_blas