aboutsummaryrefslogtreecommitdiffhomepage
path: root/blas/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2010-03-24 19:34:18 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2010-03-24 19:34:18 +0100
commit4e871c6c8082ed7f11aadfb53eef4ecc7e60c948 (patch)
tree2caafdbf9ccb53326e20ee89e05c5558e07382c2 /blas/CMakeLists.txt
parentc68098b9be036b94bc603bf31646af464810ccc2 (diff)
blas: fix compilation and build both a shared and static lib
Diffstat (limited to 'blas/CMakeLists.txt')
-rw-r--r--blas/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/blas/CMakeLists.txt b/blas/CMakeLists.txt
index e71076f9d..d1f5b5676 100644
--- a/blas/CMakeLists.txt
+++ b/blas/CMakeLists.txt
@@ -4,9 +4,9 @@ add_custom_target(blas)
set(EigenBlas_SRCS single.cpp double.cpp complex_single.cpp complex_double.cpp xerbla.cpp)
-add_library(eigen_blas ${EigenBlas_SRCS})
-# add_library(eigen_blas SHARED ${EigenBlas_SRCS})
-add_dependencies(blas eigen_blas)
+add_library(eigen_blas_static ${EigenBlas_SRCS})
+add_library(eigen_blas SHARED ${EigenBlas_SRCS})
+add_dependencies(blas eigen_blas eigen_blas_static)
install(TARGETS eigen_blas
RUNTIME DESTINATION bin