aboutsummaryrefslogtreecommitdiffhomepage
path: root/bench/btl/data/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hans Johnson <hans.j.johnson@gmail.com>2019-10-31 11:36:37 -0500
committerGravatar Hans Johnson <hans.j.johnson@gmail.com>2019-10-31 11:36:37 -0500
commit8c8cab1afdc325dfe0a3c1ad805014ea4010e208 (patch)
tree65946d241f9e757a0f745832e35fba9d44c193c9 /bench/btl/data/CMakeLists.txt
parent6fb3e5f1767855bc1a8aa3c868bc7fbf0eeb67ef (diff)
STYLE: Convert CMake-language commands to lower case
Ancient CMake versions required upper-case commands. Later command names became case-insensitive. Now the preferred style is lower-case.
Diffstat (limited to 'bench/btl/data/CMakeLists.txt')
-rw-r--r--bench/btl/data/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/bench/btl/data/CMakeLists.txt b/bench/btl/data/CMakeLists.txt
index 6af2a366f..580c1ced0 100644
--- a/bench/btl/data/CMakeLists.txt
+++ b/bench/btl/data/CMakeLists.txt
@@ -1,25 +1,25 @@
-ADD_CUSTOM_TARGET(copy_scripts)
+add_custom_target(copy_scripts)
-SET(script_files go_mean mk_mean_script.sh mk_new_gnuplot.sh
+set(script_files go_mean mk_mean_script.sh mk_new_gnuplot.sh
perlib_plot_settings.txt action_settings.txt gnuplot_common_settings.hh )
-FOREACH(script_file ${script_files})
-ADD_CUSTOM_COMMAND(
+foreach(script_file ${script_files})
+add_custom_command(
TARGET copy_scripts
POST_BUILD
COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_SOURCE_DIR}/${script_file} ${CMAKE_CURRENT_BINARY_DIR}/
ARGS
)
-ENDFOREACH(script_file)
+endforeach(script_file)
-ADD_CUSTOM_COMMAND(
+add_custom_command(
TARGET copy_scripts
POST_BUILD
COMMAND ${CMAKE_CXX_COMPILER} --version | head -n 1 > ${CMAKE_CURRENT_BINARY_DIR}/compiler_version.txt
ARGS
)
-ADD_CUSTOM_COMMAND(
+add_custom_command(
TARGET copy_scripts
POST_BUILD
COMMAND echo "${Eigen_SOURCE_DIR}" > ${CMAKE_CURRENT_BINARY_DIR}/eigen_root_dir.txt