aboutsummaryrefslogtreecommitdiffhomepage
path: root/Eigen/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2008-05-31 23:21:49 +0000
committerGravatar Gael Guennebaud <g.gael@free.fr>2008-05-31 23:21:49 +0000
commit64169389edb9f852bd7fabe15b4cc1ba909a9796 (patch)
tree0b9d70fa6a169e556bb84ff7d5645ea39fe90f94 /Eigen/CMakeLists.txt
parentfcf4457b781831b51ac70d4141b29b062d29fdf3 (diff)
added an *optional* Eigen2 dynamic library.
it allows the possiblity to save some compilation time by linking to it *and* defining the token EIGEN_EXTERN_INSTANCIATIONS
Diffstat (limited to 'Eigen/CMakeLists.txt')
-rw-r--r--Eigen/CMakeLists.txt17
1 files changed, 14 insertions, 3 deletions
diff --git a/Eigen/CMakeLists.txt b/Eigen/CMakeLists.txt
index 773344119..e4eec9976 100644
--- a/Eigen/CMakeLists.txt
+++ b/Eigen/CMakeLists.txt
@@ -1,4 +1,10 @@
-SET(Eigen_SRCS Core CoreDeclarations LU Cholesky QR)
+SET(Eigen_HEADERS Core CoreDeclarations LU Cholesky QR)
+
+SET(Eigen_SRCS
+ src/Core/CoreInstanciations.cpp
+)
+
+ADD_LIBRARY(Eigen2 ${Eigen_SRCS})
SET(INCLUDE_INSTALL_DIR
"${CMAKE_INSTALL_PREFIX}/include/eigen2"
@@ -6,9 +12,14 @@ SET(INCLUDE_INSTALL_DIR
"The directory where we install the header files"
FORCE)
-INSTALL(FILES
- ${Eigen_SRCS}
+INSTALL(FILES
+ ${Eigen_HEADERS}
DESTINATION ${INCLUDE_INSTALL_DIR}/Eigen
)
+INSTALL(TARGETS Eigen2
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib)
+
ADD_SUBDIRECTORY(src) \ No newline at end of file