aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2016-08-05 15:21:14 +0200
committerGravatar Christoph Hertzberg <chtz@informatik.uni-bremen.de>2016-08-05 15:21:14 +0200
commitfe4b927e9c8e796a07c5864e58630e888979519e (patch)
tree5cef0ce3e5eac367da0e635e2c093a290195da15 /CMakeLists.txt
parentfe778427f2aab125a1d1906192bb4d8a73a57a12 (diff)
Add aliases Eigen_*_DIR to Eigen3_*_DIR
This is to make configuring work again after project was renamed from Eigen to Eigen3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b4d28125a..76ec09ea0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,11 @@ if(${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_BINARY_DIR})
message(FATAL_ERROR "In-source builds not allowed. Please make a new directory (called a build directory) and run CMake from there. You may need to remove CMakeCache.txt. ")
endif()
+# Alias Eigen_*_DIR to Eigen3_*_DIR:
+
+set(Eigen_SOURCE_DIR ${Eigen3_SOURCE_DIR})
+set(Eigen_BINARY_DIR ${Eigen3_BINARY_DIR})
+
# guard against bad build-type strings
if (NOT CMAKE_BUILD_TYPE)