aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-10-05 07:42:31 -0400
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-10-05 07:42:31 -0400
commitfa9fc1397ba29806da9aa29776b2b9d3830fbdb9 (patch)
tree8e1ec7d825d8691fa85343a29c24e791eb65e5a7 /CMakeLists.txt
parentb78b2ede5f6156c8898c152335176cbd47c34bdb (diff)
next attempt ... introduce EIGEN_CMAKE_RUN_FROM_CTEST, in that case don't EXCLUDE_FROM_ALL
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c3b63bc55..36b2be99f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,7 +124,11 @@ add_subdirectory(doc EXCLUDE_FROM_ALL)
include(CTest)
enable_testing() # must be called from the root CMakeLists, see man page
-add_subdirectory(test EXCLUDE_FROM_ALL) # can't do EXCLUDE_FROM_ALL here, breaks CTest
+if(EIGEN_CMAKE_RUN_FROM_CTEST)
+add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
+else(EIGEN_CMAKE_RUN_FROM_CTEST)
+add_subdirectory(test EXCLUDE_FROM_ALL)
+endif(EIGEN_CMAKE_RUN_FROM_CTEST)
add_subdirectory(unsupported)