aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2011-09-21 10:27:38 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2011-09-21 10:27:38 +0200
commitebfed5a51298fc03ad0c39c18b3ca723014d5c85 (patch)
treeb506e422eecac2d1358dd8b1b9b9a0a7823d02b3 /CMakeLists.txt
parent1d796acb05c20b09e9b8389e3919634ddf02e3ec (diff)
Enable incomplete BLAS/Lapack builds when no fortran compiler has been found.
Works here with gcc. Hopefully this will work for MSVC too.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c37c96e9..ab44f22c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -343,15 +343,13 @@ else()
add_subdirectory(test EXCLUDE_FROM_ALL)
endif()
-if(NOT MSVC)
- if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
- add_subdirectory(blas)
- add_subdirectory(lapack)
- else()
- add_subdirectory(blas EXCLUDE_FROM_ALL)
- add_subdirectory(lapack EXCLUDE_FROM_ALL)
- endif()
-endif(NOT MSVC)
+if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
+ add_subdirectory(blas)
+ add_subdirectory(lapack)
+else()
+ add_subdirectory(blas EXCLUDE_FROM_ALL)
+ add_subdirectory(lapack EXCLUDE_FROM_ALL)
+endif()
add_subdirectory(unsupported)