aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2010-06-28 00:05:11 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2010-06-28 00:05:11 +0200
commitde1220aa62b8ec06dc608e86e023ce2b25658642 (patch)
tree6ef440698ac6f546a91fabe80f4ba7a13dde079a /CMakeLists.txt
parentca29620e25be0d4a5f6dccd9a4c5c4c649cee35c (diff)
add a Transposition section in page 2
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6adfd6429..45b109d9a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -220,6 +220,17 @@ else()
)
endif()
+# similar to set_target_properties but append the property instead of overwriting it
+macro(ei_add_target_property target prop value)
+
+ get_target_property(previous ${target} ${prop})
+ # if the property wasn't previously set, ${previous} is now "previous-NOTFOUND" which cmake allows catching with plain if()
+ if(NOT previous)
+ set(previous "")
+ endif(NOT previous)
+ set_target_properties(${target} PROPERTIES ${prop} "${previous} ${value}")
+endmacro(ei_add_target_property)
+
install(FILES
signature_of_eigen3_matrix_library
DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Devel