aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2013-03-01 14:50:20 +0100
committerGravatar Gael Guennebaud <g.gael@free.fr>2013-03-01 14:50:20 +0100
commitd2e5c9d8921810a4f4fd5588b24c37b4cee768fd (patch)
tree4f755ab93550f14170c59653d5e02f0087da0aae /CMakeLists.txt
parentb9fe79153b87d99022859bd65547a7c67e01c41d (diff)
Do not globally disable stupid warnings in our unit test since such warnings do affect user code.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ff21a9802..2003e15a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -105,8 +105,6 @@ if(EIGEN_DEFAULT_TO_ROW_MAJOR)
add_definitions("-DEIGEN_DEFAULT_TO_ROW_MAJOR")
endif()
-add_definitions("-DEIGEN_PERMANENTLY_DISABLE_STUPID_WARNINGS")
-
set(EIGEN_TEST_MAX_SIZE "320" CACHE STRING "Maximal matrix/vector size, default is 320")
if(CMAKE_COMPILER_IS_GNUCXX)
@@ -169,7 +167,7 @@ if(CMAKE_COMPILER_IS_GNUCXX)
option(EIGEN_TEST_NEON "Enable/Disable Neon in tests/examples" OFF)
if(EIGEN_TEST_NEON)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfpu=neon -mcpu=cortex-a8")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfpu=neon -mcpu=cortex-a"8)
message(STATUS "Enabling NEON in tests/examples")
endif()