aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hauke Heibel <hauke.heibel@gmail.com>2009-12-12 11:39:07 +0100
committerGravatar Hauke Heibel <hauke.heibel@gmail.com>2009-12-12 11:39:07 +0100
commitd088ee35f644f9178270f0c3dc8c76011d208099 (patch)
tree47001aacbb83eba02c38d93ec97fbe09e7c8497c /CMakeLists.txt
parent494a88685ee995b34da0f3b79a68fa06c0ee63ff (diff)
Added to possibility to compile unit tests at maximum warning level.
Silenced (amongst others) many conversion related warnings.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d1d9b12de..a7d4089c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,7 +124,8 @@ endif(EIGEN_TEST_NO_EXPLICIT_VECTORIZATION)
option(EIGEN_TEST_C++0x "Enables all C++0x features." OFF)
-option(EIGEN_TEST_RVALUE_REF_SUPPORT "Enable rvalue references for unit tests." OFF)
+option(EIGEN_TEST_MAX_WARNING_LEVEL "Sets the warning level to /Wall while building the unit tests." OFF)
+mark_as_advanced(EIGEN_TEST_MAX_WARNING_LEVEL)
include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR})