aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Jitse Niesen <jitse@maths.leeds.ac.uk>2009-11-13 13:05:57 +0000
committerGravatar Jitse Niesen <jitse@maths.leeds.ac.uk>2009-11-13 13:05:57 +0000
commitd07c05b3a5e338a018e7b0992f32f45ef2f12495 (patch)
tree9ba0fd90431cd76edddc21439ca89bf8aa230370 /CMakeLists.txt
parent7e3c4096d88372f68991671474039100386c33be (diff)
Build tests for unsupported modules if EIGEN_LEAVE_TEST_IN_ALL_TARGET
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8bc7d4754..09934cdcc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -132,9 +132,9 @@ add_subdirectory(doc EXCLUDE_FROM_ALL)
include(CTest)
enable_testing() # must be called from the root CMakeLists, see man page
if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
-add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
+ add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
else()
-add_subdirectory(test EXCLUDE_FROM_ALL)
+ add_subdirectory(test EXCLUDE_FROM_ALL)
endif()
add_subdirectory(unsupported)
@@ -171,4 +171,4 @@ endif()
message("")
message("To build/run the unit tests, read this page:")
message(" http://eigen.tuxfamily.org/index.php?title=Tests")
-message("") \ No newline at end of file
+message("")